.mgcb keeps opening in Visual Studio

Whenever I double click the Content.mgcb in my Solution Explorer, it opens as a file in Visual Studio instead of opening the Pipeline.exeprogram. I need to manually set the Pipeline.exe as the default program within Visual Studio. However, every time I launch Visual Studio, it resets to the JSON editor instead.

Does anybody know how to force all .mgcb files to open with the Pipeline.exe tool always?

Opening the .mgcb file in Windows Explorer opens it in the Pipeline tool. So it seems to be a setting in Visual Studio.


Right Click > Open With > Pipeline > Set As Default > Open

I do that, but every time I restart Visual Studio, it reverts.

I know it’s an old topic, but I’m having the same issue with VS Community 2019. Anyone else?


I’m having the same issue. I just work around it by right clicking on the mgcb file and choosing Open With.

Same issue for me

Yeah same issue here. Already Set as Default, but it still opens as this Visual Studio text file instead of the Tool itself directly.

Same but i installed the editor about 2 months ago that was bugged and actually crashed.
I believe the version im running is… 1375.
The odd thing is vs 2017 still opens it and uses the new tool of course.
On the other hand i can switch the .mgcb to be opened with other applications in vs2019 and they work.

I should try to dl a new version but if it screws up i don’t feel like messing with it right now i have a feeling its just because this version is messed up but no one else has told me they can actually double click a mgcb file in vs2019 solution explorer and it will open so i guess i wont be sure till i try a newer copy.

I can repro this, quite a strange bug in vs, however here is a workaround for now:

  • Right click > Open With
  • Click “Add…”
  • Select the following program (replace harry with your username): C:\Users\harry\.dotnet\tools\.store\dotnet-mgcb-editor\\dotnet-mgcb-editor\\tools\netcoreapp3.1\any\mgcb-editor-wpf.exe
  • Press Ok
  • Press “Set as Default”

I went through the monofame 3.8 installation yesterday including running the command to associate the mgcb files to the editor. I created a new solution in 2019 and it still has the issue - double clicking the mgcb file inside Visual Studio 2019 opens it as a text file.

Double clicking the mgcb file from the folder however, opens it with the MGCB Editor.

So it looks like a VS 2019 issue.

1 Like

Yup, this worked, thank you

Worked for me too - thanks!

Is this an issue? Imo, feels more like a plus.

This worked for me too, many thanks!

Thanks so much!