MonoGame 3.8.1

I linked it here. The updated migration guide isn’t online on the documentation site yet.


For some reason the file .mgcb file association didn’t happen when I installed the extension so I manually set it to run "C:\Users\username\.nuget\packages\dotnet-mgcb-editor-windows\\tools\net6.0\any\mgcb-editor-windows-data\mgcb-editor-windows.exe", which works for now.

*(Not recommended). See below for better solution.


Something that confuses me… I see some users celebrating being able to use .NET 6 now, but… haven’t we already been able to do that? I’ve been using it for some time now in my current project. Or is that because I built it from source that I’ve been able to do that?

1 Like

It was already possible for some platforms. Now it’s much more unified. (Also the pipeline was locked to .NET Core 3.)

The MonoGame repo is a lot cleaner too if you compare it with MonoGame 3.8.0 or even 3.7 one. I think the onboarding for new collaborators should be a lot more straight forward.

1 Like

Before 3.8.1, MonoGame was a frankenstein kind of framework with different pieces requiring different .NET versions. Things are now much more smoother and future-proof.

The extension doesn’t associate files because the way .NET 6 works with tools doesn’t allow that, and by associating it manually, you’re pretty much opening yourself to future version mismatch.


My solution was a temporary botch. I’ve since changed it by right-clicking Content.mgcb in VS2022 and then Open With... and choosing MGCB Editor as the default. Didn’t seem to work yesterday but does now.

Awesome! I can’t wait to try this out! :slight_smile:

im trying microsoft upgade-assistant and its doing alot of this flawlessly so far…even updating netstardard libs with MG game stuff, to net 6 , and changes the monogame refs to the latest ones on nutget .

updating to mg 3.81 from 3.8 even if you are using netcore 6 already , can be a big deal for legacy projects. because Netstandard 2 is nearly dead, but Microsofts command line updgrate assistant does almost everything i did yesterday for me at least for vs 2022 preview slns. so I am trying that whch that almost ported my almosgt all of my wpf app to netcore 6 and Ill report if it works… it even updates your Monogame refs for you.

just run on cmd line

dotnet tool install -g upgrade-assistant
then donet tool upgrade-assistant analyze XXX.sln

then upgrade-assistant upgrade XXX.sln

when i targeted androind entry point,
it didnt not strip out the xaramin junk from the android target but warned me its unused.
but with a clean templayhte but i dont think xamarin is gone yet… as far as build and deploy its stiill slow…

as for MG and WPF legacy level editors , i hit a brick wall, but there is hope there as well. the wpf even wiht old docking and scripting libs, did port to netcore 6 and run, aboutg 99% was ok.

on a big legacy wpf and MG tooling rig and game , this looks like its an all or nothign deal for me … i cant link a 4.8 wpf exe to any netcore 6 libs so i cant run MG in wpf using net 6 game code in libs. and Netstandard 2.0 is quite nearly dead… but there is a compatibililty mode and some other ways around. but for my thing level editor WPF + monogame core… …last time i tried on vs 2019, the Compatibilly Analyser gave me a 99% so i went ahead with up and the WPF tool worked except for the monogame integration and a few details. …

ill try this again . the upside is there wpf level editor becomes mutliplatfrom. now that some parts work on the new MG. and see… if i can fix the sdl issue .

**Port from .NET Framework to .NET 6 - .NET Core | Microsoft Docs
but im going to Overview of the .NET Upgrade Assistant - .NET Core | Microsoft Docs

i think if this goes through i thnk should be mentioned as a way to update older MG projects all over the github that arent maintained because i just presse 1, and enter a bunch of times, diff and its doing what your guilde says to do and much more. could save someone days of work or worse, htting a brikc wall, havng to bail out and downgrade because of older dependencies. but i dont know about the maui, or the wpf, , ill halfway through it… jjust though id mention it now because thats how the front line approach should be done i think with any legacy code thats, should do this… at least on windows and vs 2022 mabye more… would have saved me a day…

1 Like

I had the same issue as you. i ran this command in the terminal and I now see all templates:

dotnet new --install MonoGame.Templates.CSharp
1 Like
  1. Add official source, command:
    dotnet nuget add source "" --name "NuGet official package source"
  2. Restart VS
  3. Update packages in Nuget Manager (change “official package source” on button right-up)
  4. Build and run
  5. Done

Thanks it works for me :+1:

I see an unexpected error
with MGCB editor
the build is functional with Android when I load the textures everything is fine
on the other hand on an Ios project it builds all green but I have this error
The content file was not found.

1 Like

i had it working before with net 6 on just the targets, got a huge boost and then found updating netstandand 2.0 dlls linked to MG necessary but when i went ahead and updated everything esle, like my data and physics to net 6 libs, that was easy ,and came with another exiting obvious 20+% performance boost. if you dont have too much legacy stuff … you might be able to get more performance than from the earlier net 6 way+ netstandard 2.0 game cores, plus the new fixes. but android has a lot of flux going on… Upgrade-assistant might help you if you have legacy net48 stuff…

How can I install the MonoGame v3.8.1 (hotfix) extension in Visual Studio for Mac?
I have downloaded and installed MonoGame.Templates.VSMacExtension_3.8.1.303.mpack from this link:
But in Visual Studio for Mac 17.3.1 (build 411) it displays that the extension is disabled and I can not find the MonoGame templates when I want to create a new project. Why is the extension disabled?

EDIT: I found out that the templates are only displayed right after I installed the MonoGame extension. If I quit Visual Studio and reopen it then the templates are no more displayed when I want to create a new project. I successfully created an Android and an iOS project.

1 Like

Hi, I have the same problem. VS for Mac ver 17.3.1 (build 411). After instal MonoGame Extension is Disabled. But MonoGame templates are available, I can create monogame project, and I can compile and run the project. But I can’t use content editor. When I click on Content.mgcb nothing happend.
VS ver
Zrzut ekranu 2022-08-22 o 09.17.10
Installed Extension
Zrzut ekranu 2022-08-22 o 09.20.03
Zrzut ekranu 2022-08-22 o 09.20.31
I moved to Mac from Windows a few days ago and the problem immediately :slight_smile: Maybe someone can help?

@mrhelmut ,
Should we still expect an update soon or will be the latest version for a while?

1 Like

I need to right click Content.mgcb and and choose it to open it. But the problem is, sometimes it crashes when I open it.
But I still have the templates problem. They are not available when I want to create a new project.

With templates is simple trick (annoying but simple) - when you start VS, go to Extensions (from Visual Studio menu), Installed, highlight MonoGame Extension and click - Disable, and next Enable, then try to create new project. You should see MonoGame templates. But you must to do that, every time when you start VS and you need to create new project :confused:

But as for MGCB Editor, that on my VS content manager not working, even I click right mouse button and choose Open with… and MGCB Editor.

Thanx. The simple templates trick works for me. You could try to uninstall the extension and install it again from file and then right click Content.mgcb in a MonoGame project before quiting VS.

i am using mac and when i compile with MGCB editor it works fine

on the other hand when I call my texture it tells me that it is not found
Has anyone encountered this problem before?