Monogame doesn't run on a 2.3.5 (API 10) Android phone

I thought the minimum requirements to run on Android was 2.3 (API 9) but I keep getting the error
“The device does not support the minimum SDK level specified in the manifest.” when running on a 2.3.5 phone (HTC Desire HD)

I tried changing the minimum SDK to a lower one but I still get this problem.

Any ideas?


Can you post your manifest ?

What I just did was to create an empty game using the “Monogame Android project” template on VS2017 and the latest monogame. I modified the properties of the manifest by going to the project properties, and this is what it did:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="" package="Game7.Game7" 
android:versionCode="1" android:versionName="1.0" android:installLocation="auto">
<uses-sdk android:minSdkVersion="10" />
<application android:label="Game7"></application>

I think the min is 2,3.6 rather than 2.3.5.

Ok, good to know then. Thanks.