SOLVED: new project in monodevelop complaining about Game1 being missing

I’m totally new to monodevelop. I downloaded the whole package including monogame 2.5 onto Ubuntu. I started a new project and it ran fine. I added a couple of things like escape to quit the app–again that worked fine. I wanted to add some content to test it in the spritebatch, but it wasn’t being found at runtime even though it was in my content directory. I tried changing its properties like “compile as a resource”, but then I started to get a different error “The type or namespace name ‘Game1’ could not be found. Are you missing an assembly reference?”. I’m at a loss what I could have done to keep my app from compiling at this particular line in Program.cs. Again all I did was change some properties of the content file.

You accidentally changed the properties of Game1.cs to compile as a resource. Just change it to Compile and you will be able to compile again.

Now for loading resources, do the following: Translate Windows XNA game to Monogame.
And if you need the newest monogame(3.2): How to install Monogame 3.2 in Ubuntu 14.04?
And since you are unable to compile fonts from linux use these precompiled fonts::!iJgSBbyZ!bxZpuAXDUsGPqlsij5mTpA

1 Like

Yes, that was it. It compiles and I can use content files, too. Thank you.