Visual Studio 2017 UWP Project failing to create

On a fresh install of Visual Studio 2017, and a fresh install of Monogame 3.6, I cannot get the Monogame Windows 10 UWP templates to create successfully. I get an error stating “The Project requires a platform SDK (10.0.14393.0) that is not installed.”

When I view which version of the SDK I have installed, I see 10.0.10586.212 and 10.0.15063.468 and 10.0.16299.15. When I google search for the 10.0.14393.0 version I cannot find any installer.

Changing the target/minimum to 10.0.16299.15 results in a project creation failed alert in the lower status bar.

I have uninstalled and reinstalled everything several times now. Any idea what I am doing wrong?

This did not fix my issue. However, I did manage to fix it by installing the 3.7 development build of MonoGame.

You just needed to set both to 10240, but that’s good.

I tried every possible combination of target / minimum, none worked. Some would produce an error saying a SDK version was missing. Others would simply result in a “project creation failed”.

You just needed to install the 10240 SDK

I might put together a tutorial for a from fresh install, soon…