3.7 to 3.8 - Invalid / Missing Processor for custom Pipeline Extensions

Hello all,

I’m trying to upgrade a 3.7 game to 3.8. I’ve created 3 new projects in the same solution from the Nuget templates:

  • a MonoGame Cross-Platform Desktop Application (OpenGL)
  • a MonoGame Pipeline Extension, and
  • a MonoGame Shared Library Project

I then copied all the files from the original 3.7 projects except the csproj files (Visual Studio didn’t like them) into the new 3.8 projects.

What I’m finding is that MGCB utterly fails to detect the processors and importers in the Pipeline Extension project.

I tried adding a project reference to the Pipeline Extension, but I get a little warning icon (I assume because the two projects reference incompatible .Net Core and .Netstandard libraries) and it has no effect on the errors.


The MGCB file does seem to have a reference to the pipeline extension, but in spite of that it’s still not functioning.

#-------------------------------- References --------------------------------#


At this point, I’m exhausted and at an utter loss. Does anyone know what I’m doing horribly wrong?