After publishing in 3.6, The installer doesn’t run and debugging it throws a new error


i try to publish the game i made for Windows. I have the exact same problem as this Topic i’ve tried the solutions given but none works.

I just installed 4.6.2 .NET, non of the check box mentioned are checked, i work on W7 enterprise SP1 with visual studio 2013.

Any help would be appreciated :slight_smile:

Hey Paul
I hope this is still helpful since it’s been about a month.

Recently the problem popped up again for me with the latest .NET framework. This time supaevensteven’s solution from the post you linked fixed it, but at some point the settings all started changing back whenever I published and they couldn’t be set permanently.

Apparently using Visual Studio’s “publish” option will reset those values since it’s designed for ClickOnce deployment (weird that I’d never had this happen before). Instead of publishing you can build & run your project in “Release” mode and the application created in “Project/bin/…/Release” can be copied out and distributed instead of a ClickOnce application.

Not sure how “shipable” it is since you need to have some prerequisites installed to run the game from the application, I’ve been trying to use NSIS to replace the ClickOnce installer.

Wish I’d found this out sooner, hope it helps!

I have used the “ClickOnce” deployment for Windows Forms applications in the past. It is something I never liked since it appears to be noting more than a quick fix for deployments on a network.

There are a number of freely available installers that you may want to try instead of the Microsoft solution.

I haven’t tried it yet but Advanced Installer appears to have a fairly complete free installer you can experiment with…

Advanced Installer