An Unexpected warning

HI there,

Today, without any modification on my project (except the fact i made a copy of the project folder in order to keep a previous version to work on the new folder project created (don’t bother teeling me using git i will not), 4 warnings like this one appeared :

Warning 2 The element 'PropertyGroup' in namespace '' has invalid child element 'ContentRootDirectory' in namespace ''. List of possible elements expected: 'Property, AllowUnsafeBlocks, AppConfigForCompiler, ApplicationIcon, ApplicationRevision, ApplicationVersion, AppDesignerFolder, AspNetConfiguration, AssemblyKeyContainerName, AssemblyKeyProviderName, AssemblyName, AssemblyOriginatorKeyFile, AssemblyOriginatorKeyFileType, AssemblyOriginatorKeyMode, AssemblyType, AutoGenerateBindingRedirects, AutorunEnabled, BaseAddress, BootstrapperComponentsLocation, BootstrapperComponentsUrl, BootstrapperEnabled, CharacterSet, CheckForOverflowUnderflow, CLRSupport, UseDebugLibraries, CodePage, Configuration, ConfigurationName, ConfigurationOverrideFile, CreateDesktopShortcut, CreateWebPageOnPublish, CurrentSolutionConfigurationContents, DebugSecurityZoneURL, DebugSymbols, DebugType, DefaultClientScript, DefaultHTMLPageLayout, DefaultTargetSchema, DefineConstants, DefineDebug, DefineTrace, DelaySign, DisableLangXtns, DisallowUrlActivation, CodeAnalysisAdditionalOptions, CodeAnalysisApplyLogFileXsl, CodeAnalysisConsoleXsl, CodeAnalysisCulture, CodeAnalysisFailOnMissingRule.... C:\Program Files (x86)\MSBuild\MonoGame\v3.0\MonoGame.Content.Builder.targets 23 8 Miscellaneous Files

What is happening ? How do i solve this ?



use mercurial and check this similar issue:


Yeah maybe that solve the problem like putting a bit of tape to repair a broken chair, it will work awaiting for a real solution :frowning:
To solve the issue, i built the project.

In addition, i have these errors (not warnings) coming up :

Error 6 The command ""C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\MGCB.exe" /@:"D:\CURRENT PROJECT\DRONE AGENT nuArchi\404\DroneAgent\DroneAgent\Content\Content.mgcb" /platform:DesktopGL /outputDir:"D:\CURRENT PROJECT\DRONE AGENT nuArchi\404\DroneAgent\DroneAgent\Content\bin\DesktopGL" /intermediateDir:"D:\CURRENT PROJECT\DRONE AGENT nuArchi\404\DroneAgent\DroneAgent\Content\obj\DesktopGL" /quiet" exited with code 5. Please verify that you have sufficient rights to run this command. C:\Program Files (x86)\MSBuild\MonoGame\v3.0\MonoGame.Content.Builder.targets 89 5 DroneAgent

Error 1 Object reference not set to an instance of an object. D:/CURRENT PROJECT/DRONE AGENT nuArchi/404/DroneAgent/DroneAgent/Content/Sprites/Pieces/earth_square.png DroneAgent

I have checked the settings of that file and it is the same settings as other files that don’t have any problem like this.

It seems to be related to rights but i changed nothing nd suddenly since a week it is making this every morning and it can be solved by a simple build. It is annoying.

Thanks for your kindness :slight_smile:

Well sorry if it was rude. Thanks for the help.
But i hope monogame staff will have an answer saying why it is broken all of a sudden.and how it will be permanently fix.

Heh, that makes it sound like people get paid for this :stuck_out_tongue:

From the error it seems that the MonoGame.Content.Builder.targets file doesn’t get loaded correctly. No idea why or how to fix though.

Aaaargh!!! What’s wrong with Git/other VCS? Sure you have to invest a bit to learn it, but it really really really really really really really really really pays off. Really. Especially when collaborating. Sorry for telling you anyway

staff = team not necessarly paid team to me.

I am not collaborating in this project. I already used git, it was a lot of issues for me. I hate it. Forced me to re-clone 7 times a project for reasons out of my scope. I hate it a lot, A LOT. (don’t bother teeling me using git i will not)

No problem :slight_smile:

I don’t think this is a MonoGame problem (I’m talking about the warnings), it looks more a Visual Studio problem than a MG problem. The proof is that several other people (from the links and links following the links) have had the same problem without using MonoGame. And in fact, they’re talking of the problem in VS2010, VS2013 and VS2015, so it’s been there at least for 5 years, and MS still hasn’t fixed it.

1 Like