ArchLinux error cp: cannot create regular file on install

On Arch Linux, when I run chmod +x followed by sudo ./ I get the following output.

Verifying archive integrity… All good.
Uncompressing Monogame Pipeline Installer…

  • mono-runtime…[Found]

Continue (Y, n): Y
Installing MonoGame SDK…
Creating launcher items…
cp: cannot create regular file ‘/etc/bash_completion.d/mgcb’: No such file or directory
Installing man pages…
Adding mimetype…
touch: cannot touch ‘/root/.config/mimeapps.list’: No such file or directory
/usr/bin/xdg-mime: line 872: /root/.config/ No such file or directory
Installation complete

  • To uninstall MonoGame SDK you can run ‘monogame-uninstall’ from terminal.
  • To install templates for MonoDevelop, go Tools > Extensions > Gallery > Game Development > MonoGame Extensions, and install it.
  • To install templates for Rider simply run ‘dotnet new --install MonoGame.Templates.CSharp’

Checking for the missing directories myself they indeed do not exist. While the script didn’t warn me about it I am unsure whether or not I have the correct openal dependency. There is no libopenal-dev package on arch, but I do have the openal package installed.

If I ignore the errors and try to create a project in MonoDevelop 7.8 preview with the MonoGame Cross Platform Desktop Application template a red x appears next to ExampleGame.Desktop with the error: Invalid configuration mapping. Running the game without debugging gives me the following error:

Cannot open assembly ‘/home/(my name)/Projects/ExampleGame/ExampleGame/bin/DesktopGL/Any CPU/Debug/ExampleGame.Desktop.exe’: No such file or directory.
The application was terminated by a signal: SIGINT

Does anyone know of a fix to this issue?
I have also tried building monogame from source with no success. I’ll try to post the build errors when I get a chance later.

Fixed this by opening up the .csproj and removed spaces between ‘AnyCPU’, wherever they occur.

I just tried that, but when I open the project again I still have the same issue. Monodevelop creates another Any CPU folder with an empty Debug directory. Also, when I open the .csproj for the first time, I am given no errors and can run the game without issue. However, the second time I open it the invalid configuration mapping error comes back.

EDIT: Never-mind. while the invalid configuration mapping error stills shows up the second time I open the .csproj file it does still compile. Renaming the Any CPU folders still breaks it though. When you say you removed spaces between Any CPU, do you mean in the code or in the folders? The Any CPU folders do not show up in the solution, but I can modify them in the terminal.

I’ll see what happens when I copy-paste some code in from the tutorials.

EDIT 2: I ran a test using this tutorial to make a square go across the screen. everthing works fine on the first load of the .csproj file and I was able to make changes (in my case changing the start position of the square) but if I restart monodevelop or otherwise have to re open the .csproj file it wont accept changes. No errors given and the game still runs, but no changes are loaded. If I click rebuild it breaks the project an will no longer build. I figured C# development on linux would be less straightforward on linux but damn.

It may also be necessary to modify the AssemblyInfo.cs; furthermore, I nuked any instance of .Desktop so that just the project name was left. Not sure if that’s a part of the issue or not. May also be necessary to change the project settings within MonoDevelop, though I would assume those modify the .csproj

I can’t say I’ve experienced the same issues that you have in your latest post.

Unfortunately I am still getting the same issues as before. Looks like I’m in over my head on this one, so I’ll probably just use monogame on windows instead. Thank you for the help.