Are mesh's of type *.obj no longer supported?


So, setting up my new dev rig, installed the latest MonoGame, found and fixed an issue with the font importer, and now I am finding that *xnb files that have been buit from a *.obj file now throw an exception.

Are *.obj mesh’s no longer supported?

Here is the error I get:-

This works fine on my old machine, forget what version of MonoGame it has on it, but it’s not the latest.

Anyone know how I can resolve this?

Thanks in advance,


Use the fbx processor for your model. It will work even though it’s an obj file because we use an importer that supports a bunch of formats.

Ok cool ill try that if not already. It is building to xnb, just then errors on load at runtime…

Yeah, this is an old issue that we completely lost track of:

Hmm, OK, so, it worked in my older MG build (3.6.0 I think), so, I must have set that in my old content pipeline right? so why is it occurring now, I just pulled the code off my repo, it should be set at it is in the last MG version right??

I am a t work now, so can’t validate this yet…

Yea, so on my work machine (thankfully I have a build on here), the obj file build like this:-

Builds and runs fine, are you saying in later builds (post 3.6 in this case) I need to set it to the FBX importer like this:-

Just checked and it holds up for the obj file when I run it in 3.6

That’s correct.We broke the assimp importer somewhere after the 3.6 release.

1 Like

Yay, works now thanks @Jjagg, as ever you are a star :slight_smile:

Got my bunny back lol

1 Like

Always happy to help! :slight_smile:

1 Like