Assembly not found for framework .NET Framework 4.5

I’m just trying out monogame, I know a bit of C#, Java, and Swift. I was trying to create a basic monogame windows application from my mac but when I create just a generic game project I immediately get a ton of errors thrown at me. How do I fix this?

1 Like

I’m having the same exact issue. I’ve followed the monogame setup instructions for mac carefully, uninstalled everything, ran through it again, restarted, etc etc.

Trying to figure out why it would essentially be saying “hey I don’t have the .net assembly” when I thought that’s like… what mono is… as in it essentially represents an assembly reference which replaces the set of assemblies that would otherwise be required, including .net 4.5. But my understanding here may be limited! I tried installing mono 5.16 (I had used 5.18 cuz it said that was what was best for visual studio) but that didn’t seem to help either here.


I have the exact same problem. Just got a Mac and wanted to transition my DesktopGL project from Windows, but wanted to just start a new project first to make sure everything works.

When creating a new project, from the template list I only see these options:

I was expecting to see the equivalent to “Cross-platform DesktopGL Project”, but can’t seem to find it. So, from these I tried a Mac project but get this error at creation:

I tried creating a Windows project instead, and then I get the same problem as the original poster (reference to MonoGame.Framework not found).

Not sure what to do next, would need some help with this!

For reference, I am using Visual Studio Community for Mac v7.7.3, I tried MonoGame 3.7.1 public release as well as development version (which I think is v.3.8.something?)

So hey, I found a solution that worked for me.

Basically I got the reference to MonoGame.framework from a package.

If you go to the package section of your project, you can right-click to add a package. Search for “MonoGame” and select DesktopGL from the list. After that, I could add the reference to the framework from the package and it worked!

Actually, my project had another project for Nez, and it could not get the same reference. Luckily, by opening this project separately (not being part of my main project’s solution) I could do the same trick to make it work. And by re-opening my solution, Nez was compiling correctly.

I hope it helps y’all!