Audio playing only if launched from terminal

I’m almost ready to ship my game on steam wich uses an old (pre)3.2 version of monogame. Actually everything runs fine except for the audio wich is completely mute when the game is run from steam or by doubleclicking the *.exe file.

Running the game from the terminal via
“mono myExecutable.exe” or launching it via monodevelop “run” works flawlessly. What could be the cause of this ?

Ps. forgot to add that i run monodevelop from terminal.

  1. why don’t you update to the newer version of monogame?
  2. which version of monodevelop and monogame do you use?
  1. I currently mantain different framework versions for stability of the released games. None of them is completely up to date, as every time i update the framework new issues poke in, and i tend to update out of necessity.

  2. This version should be something between 3 and 3.2. For what i know it uses open-tk/open-al for audio.
    My monodevelop version is 5.0, it should be almost up to date with repository as i compiled from source just a few months ago.

Currently my best guess would be that somehow, for some reason, running from terminal gives me a different access to audio libraries and/or hardware… is this even possible? Testing on Ubuntu 14.04 LTS, this is a confirmed issue from the tester on a different linux machine (Ubuntu as well).

Sidenote: go to and download the newest version from there. They finally updated the linux builds

Now for the actual problem, add a script to the folder that basically says “mono game.exe” and try launching your game using that.

Sorry I didn’t mention I already did that… And the steam client is already launching via the script. Unfortunately the only time I somehow managed to run the script from Unity gui I had the same exact issue: Launching from the graphic interface the script resulted in no sound. Launching the script from the terminal instead worked.