Black screen when starting game without debugger


I ported my game from XNA + XAML to mono games. Everythings works very well when I run the game with a debugger detached to my emulator or device. But when I try to start my game without the debugger it just keeps being stuck on a black screen.

It’s defficult for me to say where the problem might be because in debugging mode there are no issus.

I am using VS2012 Express and tried every kind of emulators + my own device is a Lumia 1520.

Can anybody help me to figure this out?

No idea what the problem is, but this is how I’d start off solving it:

  • Stick a load of logging in around the problem point, dumping to a text file on the phone
  • Put in a switch to display and erase the log file on game start
  • When happy it all works, run the game without the debugger and let it crash
  • Flip the switch, reconnect the debugger, run again and trawl through what’s in your text file for clues

Hope this helps!

Hey again!

I solved my problem and it appeared it was a problem with my player ID. I am using the UserExtendedProperties to get a unique ID and somehow I was trying to get ANID from a windows 8 device instead of ANID2.

But problem solved and everything is running now better as expected! :slight_smile: