Cannot Create Monogame UWP Projects

Howdy MG Community,

It’s been some years since I was last here and the current world situation has given me a chance to dive back into playing with Monogame, but…

I’ve just done a fresh install of VS 2017 and Monogame 3.7.1 and I’ve tried to create a UWP project with some errors.

After some googling the most recent thing I found was the following thread with links to an old solution:

I following those instructions and ended up with the following error and I not I’m stuck as googling doesn’t seem to find me any answers.


Any assistance will be appreciated.

If you go to the Application properties of the project and adjust the Target version and Min version of the UWP app does that help?

1 Like

Thanks for replying.

The last error was occurring before it created the project and so no project was created.

…however I have just tried again and I get no errors, despite me having tried a system reboot yesterday.

I don’t know what was causing the error but it appears to have fixed itself.

1 Like

I’ve had several monogame errors that just “went away” on their own a day or a few days later. It’s kind of magical like that, sometimes.