Cant build custom effect.

After updating to 3.6 I cant build my project anymore.
Build output only tells me “MGCB.exe excited with code 1.”
Also happens on a new empty project with only a shader file added to Content.mgcb.
Do I need to do anything different to load shaders in 3.6?

Open up Content.mgcb with Pipeline Tool and click build, it will give you a better error.

I tried and that gives me no output.

It needs to give you some output… try disabling filter output (View -> Build Output -> Filter Output), also screenshot what you get after clicking build then.

Disabled filtering, nothing appears in the output box when i press build.

Apparently if I open the Pipeline.exe and then use the menu to load a .mgcb file I can see the build output, but doubleclicking a .mgcb file to launch it for some reason breaks output in that instance of the program.
(persists on loading a different file).

But now i can see this error.
Unexpected token ‘[’ found. Expected Semicolon, Comma, or CloseParenthesis.
for this line.
sampler shadowMap[4] = { ShadowMap0, ShadowMap1, ShadowMap2, ShadowMap3, };

This worked fine before I updated and identical array initializers with other types appear to still work.