Can't debug in fullscreen after upgrade to dev branch

After updating to 3.6 I’ve noticed that if my game is fullscreen breakpoints no longer cause Visual Studio to come into the foreground. Instead the game window gets stuck in the foreground (can’t alt-tab, task manager gets stuck behind it too) with a black screen and I have to open task manager on another desktop workspace and kill vshost32.exe. This sounds like it could be something wrong with my VS configuration, but I’m pretty sure I didn’t change anything that would be related to this behavior. Anyone have a solution?

  • Windows 10 Home Insider Preview
  • Visual Studio 2015

Windows 98SE? Windows XP? Windows Vista? Windows 7? Windows 8? Windows 8.1? Windows 10? Windows Next?

Windows 10 Home Insider Preview, Visual Studio 2015.

Glad you got the hint on the Insider Preview, fast ring or stable?

Side note, I would suggest moving up to Pro edition…

Fast ring. While I’d like to snag Pro, that’s $$ I can’t afford at the moment.

While we’re on the topic I’d like to reinforce how much of an improvement to Windows the Linux subsystem is. It’s almost like having a real dev machine lol.

While I have had a similar issue with games like BF3, this could or may not be related to the Fast Ring… try ah, can you create a second desktop in Home editions?

Yep, got 6 of 'em rn lol. That’s the only way I can get un-stuck when the problem happens.

1 Like

I’d like to point out that it wasn’t happening before upgrading to 3.6 and there hasn’t been a Windows update during this timeframe. Fullscreen debug worked normally.

1 Like

lol, well… try a fresh app and remove the possibility that is a MonoGame issue or a code issue?

Just for others wondering what this means:

Just tested it, results:

  • Fresh project with NuGet Monogame WindowsDX 3.5 functions normally.
  • Fresh project with NuGet Monogame WindowsDX 3.6 has the problem mentioned above.
1 Like

Check the GitHub repo updates/requests list thing [No idea how those things work] I think the link in on the documenttion page.

And open an issue on it.

Checked the issues tab, doesn’t seem to be any info on it.

1 Like

Then open an issue and post some sample code so those involved can quickly test and verify.

I’d also like to note here that when using the DesktopGL package it seems to work ok. It seems to be an issue with the WindowsDX package only.

1 Like

AFAIK this has always been an issue. The debugger and hardware full screen don’t play nice together :confused: MonoGame also has a soft fullscreen option that just makes the window borderless and the size of the display. Maybe the default changed in 3.6? Try setting GraphicsDeviceManager.HardwareModeSwitch to false.


That seems to have fixed it. I’ll go back into 3.5 with a new project and set HardwareModeSwitch to true to confirm.

Fullscreen exclusive mode doesn’t like switching back to Visual Studio when something breaks, either a breakpoint or exception. I remember having fun with this all the way back in the early days of DirectX. A reason to have dual monitors (which I couldn’t live without now) and to use soft fullscreen mode.

1 Like