Can't install MonoGame templates (have tried using development build)

I have tried to install MonoGame on VS2017 using the latest download on the website, including the development build. Both times it gives me an access denied error and cannot install the templates. I’ve tried running as Admin. Any other solutions?

It might help if you give more details on this.

Have you checked the file size of that file, alternatively, try redownloading the package, also what antivirus apps are you running besides the standard ones with Windows?


Wait, writing? Try deleting the file…

There is no file in that folder. I have tried downloading the package multiple times. I do not use any antivirus apps besides standard Windows.

Delete the folder…

I mean there is not even a MonoGame folder, just Visual C#. It’s a fresh install of VS. I also tried creating a folder for MonoGame which didn’t work either.

Like so?

Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#\MonoGame

Yes, exactly like that

Hmm… usually manually creating the folder works… some people say they move the MonoGame folder or C# folder one hierarchy up or something in previous threads…


Can you try the 3.5 downloads? or 3.6…

I tried 3.6 and received the same error.

However, 3.5 did work.

But I would much rather use the latest version if possible… especially since I had 3.7 installed on VS 2017 last year and it worked fine.

Is there no other solution to get the latest version of MonoGame working?

Download from Git? [extra words because too short]


Turns out the default windows firewall has a ransomware / controlled folder access option that I didn’t realise was turned on. I just switched it off and everything started working fine.

I basically replied to this in your other thread.