Can't Install Visual Studio 2010 Templates for C#

I tried to install MonoGame with Visual Studio 2010, but when I got to the installer, the option to install the VS 2010 Templates was greyed out.

Here are some details on what exactly I’m using:

  • OS: Windows Vista Ultimate x64 SP2
  • Visual Studio Version: Microsoft Visual C# 2010 Express

I’m a complete newbie to MonoGame, so sorry if I’m missing something. I checked the system requirements (, but they were empty, so I just kind of assumed that what I’m using right now works.

Thank you for your time.

Yeah, I don’t know why it’s grayed out or if they stopped supporting it. I think I’ve heard it has something to do with administrative rights.

Visual Studio C# 2010 Express with XNA 4.0 Refresh should do the trick until you can upgrade to MonoGame.

You could also try Xamarin Studio or MonoDevelop

Alright then, guess I’ll just wait for Monogame 3.6 and try again. Thanks!

Are you trying to install the “stable” version and not the develop one (3.6 develop branch) ?

Not sure about Vista being supported. MS has stopped its support.

Windows 7:

dev 3.6

So first off, I just thought I’d quickly mention support for Windows Vista: Vista is still under the Extended Support phase, and so is Windows 7, so it doesn’t really matter whether or not it’s still support by Microsoft, it matters if Monogame supports it in the first place. Just thought I’d clear that up.

And by the way, about my OS situation: I have Vista Ultimate with a product key, I have Windows 7 without a product key, and I even have Windows 10 Home with a product key. It’s just that I want to use Vista Ultimate because it’s the only ultimate version of Windows I have, and I want to make use out of it while I still can (I also just like how it’s designed a bit more, but this is the Monogame forum, not the Windows forum).

Anyways, sorry about that, just some nerd rage :worried:

Monogame should work on my PC. My graphics card and my OS seems to meet all the requirements that actually managed to get filled out in the documentation, so I decided to do some experimenting. And btw, I forgot to mention in my original post, I tried installing

I went to an older version of Monogame (3.4) and tried to install that version. And all of a sudden:

Oh hey! It works! But when I tried to install 3.5 again, I still got:

That. After this, I decided to do some experimenting. I booted into a Windows 7 VM, installed VS 2010 and 2015, and when I ran the 3.5 installer, I got this:

So… from this I would just conclude this thread by saying “oh I guess 3.5 only supports VS 2015”, but then YOUR screenshots completely throw that out the window, so… I don’t even know what to do now.

I actually just tried just installing 3.4 and then seeing if I could upgrade to 3.5 from that, but it still didn’t work. (and yes, I tried running the installer as administrator, it still didn’t work)

Speaking of things that just happened… I realized that there’s a hard disk in this old computer that my family is recycling, so I’ll probably just end up installing Windows 10 and VS 2015 on that disk. So I guess it isn’t really imperative that I find a solution for this issue, but it’d still be cool to just figure out what’s going on. Maybe we could finally update that blank system requirements page :expressionless:, I dunno.

So yeah. I don’t know that to do about this. I think I’ll just wait for the final 3.6 release, or until I can install that new hard drive onto my system for VS 2015 on Windows 10.

Actually, let me ask you these questions:

What version of Visual Studio 2010 are you installing Monogame with? I’m using Visual C# Express, so maybe there’s some weird restriction with that version?

Also, do you have UAC disabled or something? Because I think that can affect the way Windows handles permissions, which would tie in perfectly to what IcelYlaN said earlier about “administrative rights”.

The templates not showing up during install seems to be a quirk of Monogame 3.5 and affects all versions of Visual Studio. You will need to install Monogame then place the templates in the correct folder manually. Check out this thread:

The templates are found in the dropbox link. Unzip the download then put the entire folder here:

c:\Users\YourName\Documents\Visual Studio 2010\Templates\ProjectTemplates\Visual C#\

This should get Monogame project templates working.

All of this said, I’m not entirely sure if 2010 is supported (despite what is listed on the downloads page). I can load up and work on a Monogame project just fine, but if I ever close and reopen the project in Visual Studio, I get an error message that “this version of Visual Studio is not supported.” I’m curious if you get the same message or if there is a workaround.

1 Like

Solved my own problem. Monogame defaults to framework 4.5 and Visual Studio 2010 only goes up to 4.0. The solution is to change the framework to 4.0 as soon as a new Monogame project is created. Go to project properties -> Application -> change Framework to 4.0. This should allow a Monogame project to be closed and reopened in 2010.

1 Like

Hey, I did everything you said to do, and it works! Thank you so much for the answer!

PJSim - did you have any luck getting a project to build this way?

Setting a project to target .net 4.0 makes visual studio 2010 happy but seems to prevent a Monogame project from building. Is there a way to configure Monogame to work with a project targeting 4.0?