Can't Load .fbx from blender to monogame correctly

EDIT: See my last post for updated question.

I ve been using monogame for about 3 months but recently i tried to create a content project for the first time, and i got error missing project subtype 6D335F3A-9D43-41b4-9D22-F6F17C4BE596. I dont know if this is relevant but i had installed the newest version of monogame about a week ago (installer) , even though i never tried to make a content project before that.

I also want to add that i see the “” template file in C:\Users\user\Documents\Visual Studio 2013\Templates\ProjectTemplates\Visual C#\MonoGame, and have xna 4.0 installed.

Is there any way to just convert my .fbx to .xnb and just not use content project if its not working for me ? Even though i’d prefer to just fix my template so that it works.

EDIT: See my last post for updated question.

There is no content pipeline project in the traditional sense in MonoGame. The one you wanted to create was probably based on the XNA content project, hence requires an XNA installation.

There should be a GUI tool named Pipeline (which uses a command line tool named MGCB) to build the content for you. Hopefully someone can point out the location of these for you as I don’t use precompiled versions.

Here is the documentation for it:

I am using pipeline.exe tool, to convert an .fbx file I made using Blender (using the default Blender 2.73a export settings) to .xnb, and then manually copy and paste it in my content directory (Is this one of the correct ways to convert it properly ?).

After watching this video I saw that you have to convert the .fbx file that you create using blender, to a new .fbx file, using a tool called fbx converter 2013, and then use that file in the pipeline.exe tool, to produce the final .xnb file. Without doing that, I can’t even see my model when drawn on the screen.

With the steps I described above, I managed to see the .xnb file on my screen but it was not exactly the original model I had made. For example:

As you can see the real model I got (after the convertion with the fbx converter 2013) is much longer, whereas the one on the left (the one I draw in my game), is like packed in a small square.

If you are using blender, please let me know how do you import the .fbx to your Monogame project. (Or you can suggest to me another software you are using to make models and tell me your method of importing models to Monogame)

This is how I am drawing my model:

protected override void Draw(GameTime gameTime)

    Vector3 modelPosition = new Vector3(-25, 0, 0);
    float modelRotation = 0;
    float aspectRatio = graphics.GraphicsDevice.Viewport.AspectRatio;

    // Draw the model. A model can have multiple meshes, so loop.
    foreach (ModelMesh mesh in Brick.Meshes)
           Vector3 cameraPosition = new Vector3(0.0f, 0.0f, 50.0f);
           foreach (BasicEffect effect in mesh.Effects)
              effect.World = Matrix.CreateRotationZ(modelRotation)* 
              effect.View = Matrix.CreateLookAt(cameraPosition,
                  Vector3.Zero, Vector3.Up);
              effect.Projection = Matrix.CreatePerspectiveFieldOfView(
               MathHelper.ToRadians(45.0f), aspectRatio, 1.0f, 10000.0f);
            // Draw the mesh, using the effects set above.

Edit: I also tried exporting to .X from blender and when i converted to .xnb, loaded the model and drew it, nothing shows up.

Ok I finally realize what the problem was… my drawing code was incorrect. I tried code from msdn website and it all worked out. I am stupid. So my drawing code was wrong, monogame pipeline worked fine all this time. I just thought it was the convertion’s fault because the model was just so weird looking. Also downloading and installing all the files in the correct order (following the instructions .txt) fixed the monogame content project error i was having where I couldn’t create the project (error missing project subtype 6D335F3A-9D43-41b4-9D22-F6F17C4BE596), obviously because I hadn’t installed things properly.