Can't load font content

OK, absolute newbie here, I’m running Debian Jessie and trying to compile some stuff.

At first I thought I had to build the assets using the “Desktop GL” Platform option at the Pipeline Tool, since my plan was to run the output on this OS… when I tried to compile the code, an exception occurred asking if the xnb file was built using “Windows” option… I changed that and it worked, how come?

Anyways after I managed to show a sprite on screen, next thing I tried is adding some font, but for some reason I can’t. When I want to load the content into a SpriteFont instance, I get the following error:

Microsoft.Xna.Framework.Content.ContentLoadException: Could not find matching content reader of type Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.NodeContent, MonoGame.Framework.Content.Pipeline, Version=, Culture=neutral, PublicKeyToken=null]] (Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.NodeContent, MonoGame.Framework.Content.Pipeline]]) at Microsoft.Xna.Framework.Content.ContentTypeReaderManager.LoadAssetReaders () [0x00000] in <filename unknown>:0 at Microsoft.Xna.Framework.Content.ContentReader.ReadAsset[SpriteFont] () [0x00000] in <filename unknown>:0 at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[SpriteFont] (System.String assetName, System.Action`1 recordDisposableObject) [0x00000] in <filename unknown>:0 at Microsoft.Xna.Framework.Content.ContentManager.Load[SpriteFont] (System.String assetName) [0x00000] in <filename unknown>:0 at monogame.Game1.LoadContent () [0x0000d] in /home/me/Projects/monogame/monogame/Game1.cs:55 at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in <filename unknown>:0 at monogame.Game1.Initialize () [0x00018] in /home/me/Projects/monogame/monogame/Game1.cs:44 at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) [0x00000] in <filename unknown>:0 at Microsoft.Xna.Framework.Game.Run () [0x00000] in <filename unknown>:0 at monogame.Program.Main () [0x00010] in /home/me/Projects/monogame/monogame/Program.cs:20

Any help? thanks in advance

You have a mismatch between the installed version of MonoGame and the MonoGame assemblies that you are using. MonoGame assemblies seem to be from 3.4 or bellow while the installed Pipeline Tool seems to be from 3.5 or above.