Can't load Pipeline files with v3.5

I worked with the Monogame 3.4 without problems, but today I upgraded it to 3.5 and now I simply can’t run the game because I get the following error to every content load:

Could not load […] asset as a non-content file!

Just before installing the v3.5 I tried run the game and it worked. What need I do to it work again? I tried to setup a new project, create a simple .spritefont and load it, but I still get the same error.

This is probably completely unrelated, but have you set the project to target .NET 4.5? That should be done if it hasn’t been.

Do you end up with the xnb files in the project’s output directory? Could you post the test project with the spritefont?

@AJP no, but I changed and nothing.

@KonajuGames yes, they are there. I uploaded a sample project that also don’t works:
I put a .png file too, to show that the problem isn’t only with spritefonts.

I did some tests here and I figured something: the error only occurs on Windows OpenGL Projects. I created the same scenario on a Cross Platform Project and on a Windows Project. No error.

@RafaelAlmeida What’s the inner exception of the exception you got? It should have some insight into what went wrong.

@LithiumToast yeah, good point. I debugged the exception and received the following:

Microsoft.Xna.Framework.Content.ContentLoadException: Could not load imgs/characters/Player asset as a non-content file! —> Microsoft.Xna.Framework.Content.ContentLoadException: Asset does not appear to be a valid XNB file. Did you process your content for Windows?

I already did the rebuild multiple time, with the Platform set to “Windows” and “DesktopGL”. The project is Windows OpenGL, maybe I will need to create a new project Cross Platform and move everything?

I solved the issue moving the entire project to a MonoGame Cross Platform Desktop Project.