Can't open mgcb editor in VS2022

I know theres plenty of threads about this already and I have read them all, and also tried all and every suggestion I can find.

I simply cannot get the MGCB editor to open up in VS2022. What I’ve done.

  • Reinstalled Win 10 (not related)
  • Fresh install of VS2022 Community
  • Installed the MonoGame extension
  • Created a new OpenGl project
  • Tried to “just open the mgcb file from VS2022” as the documentation suggest. Nothing happens.
  • Installed and re-installed the dotnet-mgcb tool via the VS command prompt.
  • It says ive got the latest MGCB editor installed
  • Still nothing happens when i try to open the file. “Open as…” has the MGCB Editor set as default.
  • Located the newly installed mgcb.exe manually. Cant run that either. Nothing happens.

At this point I’ve spent more time trying to migrate my 3.8.0 projects to 3.8.1 than I spent migrating my old XNA 4.0 projects to 3.8.0… That is kind of discouraging imo.

Yet to try Mikes (se link) workaround but that should not be needed, should it?:
Continuing the discussion from MonoGame 3.8.1: