Cant Open Pipeline Tool

no idea if this Belongs here, if not please move it!

So im revisiting some old Projects from XNA 3.1
I ported one to monogame 3.6 (which i just installed)
at least VS doesnt shows me errors, but now, i need to put the needed files into the pipeline to use them in my Project!
but if i start the Pipeline … Nothing happens,
It shows up for 2 - 3 seconds in the Task Manager, But thats all
0 at all the stats in taskmanager

Thanks already for Helping

(I use Windows 10, Monogame 3.6, and Visual Studio 2017)

The forum is for all troubleshooting, so this is the right place :slight_smile:

I don’t know what this could be, maybe some dependency issue? Normally you would at least get an error message or something.

ping @harry-cpp

Well i woud try to Build it from source but i cant get the sln file for the tools ? @Jjagg

MonoGame uses Protobuild to generate .sln and .csproj files.
How you should build from source is explained in the GitHub Readme and the Documentation.

I think the tools on Windows are only included in the ‘Windows’ project (not WindowsGL or UWP).

ok @Jjagg ive got the Build from Source now, no Errors, Everything worked, BUT still the Freshly Build Isnt Showing Up…
Im trying to redownload everything and Build it again now :slight_smile:

What do you mean exactly? You don’t have any .sln files in the MonoGame.Framework folder? Those will be generated when you run Protobuild. Did you do that? If you did, did it print any errors?

This may be a symptom of the fact that you installed the 32bit version of Monogame. The Content Pipeline tool only works in the 64bit version.

@Jjagg no i was able to build it. in the Tools/Pipeline/bin/…/Debug
was the Exe
But if i run it nothing happens

@SNaidamast shoud building it myself fix it?

Ill build it again and make sure its in Release and x64

Builded it again With Settings Release | x64
but it still just closes after ~ 5 seconds

Ive got an Error Code now:
“-1073741819 (0xc0000005) ‘Access violation’”
and yes, i do start with Admin Rights, also added that in the App.Manifest

I was having problems opening my ContentBuilder as well, but it was after installing one of the console frameworks. I’m not sure if it’s the same issue you’re having, but here’s what I did to get it to open (I still do this to this day, a month or so later).

Go to “C:/Program Files(x86)MSBuild/Monogame/3.0/Tools” or wherever your Pipeline.exe is installed. Open that and (assuming it opens), use File->Open to open your project’s Content.mgcb

I’m not sure if this will help you or if it’s even relevant, but it fixed some Pipeline issues on my end.

@gap9269 @Jjagg it seems like i just had to restart my pc and it worked!
It Does NOT i just crashed and i cant open it again.