Can't Run Project on Mac

Hey everyone!

I’ve been using MonoGame on a Windows PC for a while now with no issues at all. I recently started a project with a few friends who use Mac and I know MonoGame is supposed to be able to be fully used on a Mac, so I saw no issues with that. I started helping them get set up on Mac and we’ve run into an issue.

So, we have everything installed correctly as far as we know. We can open up Xamarin Studio and create a new MonoGame project using the templates. We made a Cross Platform Desktop Project, which is exactly what we want. So, after creating the new, blank project, I tried to immediately run it to see if we get the cornflower blue window. The project builds and runs successfully with no errors, but the window simply never appears. A new “running application” appears and just has the title “mono32” but doesn’t show any windows or open anything. The Xamarin Studio interface changes to show that a project is running, but we’re never given a window of any kind.

Is there something we’re missing, like a setting? The project builds into an exe, which the Mac cannot run because it says it’s a Windows executable. Is it okay that it’s building into an exe, or should it be building into an app?

Thank you guys for any help, this is driving us crazy.

I think you need to make sure it is building as a 64-bit application. It might be trying to build as a 32-bit application.

Thanks so much for the response. That seems likely.

Do you happen to know how I can make this change? I went into the solution options and created a new run configuration that used Any CPU instead of x86 and tried rebuilding and running, but now the running file is simply called “mono” instead of “mono32” and it’s the same result.

I don’t usually use MonoDevelop or a Mac, so I don’t know off-hand where the option is.

You could consider looking into the command line build options to hunt for an x64 output…

Good luck with finding the command list though… unless it can do a sort of Intellisense thing…

Neither do I use MonoDevelop, nor Macs… and that site… sheesh…

Thanks for the link!

I learned from another source that I can run the project in 64 bit mode by calling it from the command line with the command “mono64 MyGame.exe” and it ran!

To force it to run in 64 bit mode in Xamarin Studio, you right-click on the project, select options, and under the “compiler” menu, change “Platform target” to x64. Then it’ll run from the IDE too!

As for building the project and running it outside the IDE without using the command line, that I have not figured out yet.

But thank you all for your help!

1 Like