Choosing the right Android versions

Morning everyone,

I’m looking at which SDK levels to choose when compiling my Android app, and from what I can tell online, I should do something like this:

Compile using Android version (Target Framework) should be set to the highest version possible.

Target Android version should match the above unless I have a good reason to change it.

Minimum Android version - I guess I want to go as low as possible so I can target as many devices as I can. The MonoGame docs say it’s built for API 17, but can go lower. What does this mean for the lowest level I can go?

I know that the minimum target level is restricted by the Android API features you want to use, but my app is pretty much 100% MonoGame. I have the single default activity which creates and runs my game, and that’s it. All UI is in-game. I’m probably going to add another activity with a WebView to show some help files, but that’s all.

Thanks for the help!

Not much can add really, essentially you are correct.

Seems to me people don’t really bother targeting anything less than Android 4.2 (API Level 17), so I wouldn’t worry about that.

1 Like

That would have been nice but I am afraid recent version will crash on devices lower than 4.4 due to recent commits and errors with the fallback code.

1 Like

Thanks for the replies! I’ll try different versions in the emulator, but I guess 4.4 would be fine. The distro dashboard shows that only ~4% of devices are lower than 4.4.

I pushed a PR with my fixes for those issues,

Ah cool - thanks for the update :grin: I’m using the stable version 3.7.1 - I guess I’ll have to download the latest from GitHub and compile from source?


Once’d it’s merged yes, you can download the latest SDK builds from under the ‘Development Builds’.