Compile 3.3 in Ubuntu 14.04

I wanted to try out MonoGame for the first time, so I installed all the dependencies following this guide. But, MonoGame 3.3 does not have a Linux download, so I cloned the git repo.

After cloning the git repo I ran mono Protobuild.exe, which generated the project files for MonoGame. Then I ran xbuild MonoGame.Framework.Linux.sln to try and compile it. Turns out that I’m missing OpenTk assemblies.

As I’m quite new to C#, Mono and all of this, if someone could tell me step by step how to add OpenTK assemblies to the project and compile MonoGame for Linux, it would be great!

For monodevelop addin use:

Thanks, but I prefer compiling it myself. Can you tell me how you did it?

git clone [monogame git]
cd MonoGame
git submodule init
git submodule update
mono Protobuild.exe

Open monodevelop and build Linux sln file

go to Installers/Linux

there is no xs addin

Thanks! The steps I was missing were with the submodules (I had no idea they were submodules).

Could you add this to the documentation? Or I could do it myself if you’d prefer.

I see the docs have been updated. Thank you!