Content fails to load on Raspberry Pi


I’ve have recently been working on a project, which I would like to try to get running on my raspberry pi. However, when I try to run the program (both through mono and dotnet core) I get an error: System.IO.FileNotFoundException: Could not find file “*.xnb”, Yet the file clearly exists. note * is the first loaded file. I’ve also set the target platform for Content.mgcb to Raspberry Pi. Is this a bug with MonoGame, an issue with the PI, or have I done something wrong?

Thanks in advance.

I sense you added .xnb to the file names?

Post your loading code, and are you running Windows 10 iot? or Linux? just curious.

Here is the code I use:

Add = content.Load<Texture2D>("Sprites/buttons/Add");
Minus = content.Load<Texture2D>("Sprites/buttons/Minus");

I am using a shared project, so maybe that might be the problem? The project works fine on DesktopGL and DirectX, so it might not be code related.
The Pi is a Pi 4, running Raspbian (Linux).

I’ve also tried to build the project on the Pi, but all the content using MonoGame importers fails. I tried using 3.8 and 3.7, but I got the same error regardless.

I can’t help you with Linux but, what size are your textures?