Content Pipeline Tool won't start on Ubuntu 17.04

I’m slowly trying to migrate my development environment to Linux (Specifically, Ubuntu 17.04.) I’m trying to debug some Linux-only issues with my game and also migrating resources to Content Pipeline.

I prefer to use the Content Pipeline GUI, however, in my terminal, when I run monogame-pipeline-tool, this happens.

michael@ubuntu:~$ monogame-pipeline-tool 

Unhandled Exception:
System.TypeLoadException: Could not load type 'MonoGame.Tools.Pipeline.Styles' from assembly 'Pipeline, Version=, Culture=neutral, PublicKeyToken=null'.

Seems to me like either an issue with Reflection or a type that depends on an assembly that couldn’t load. I just updated to Ubuntu 17.04 today from 16.04 LTS - haven’t tried running the pipeline on the previous Ubuntu release, so I’m not sure if the distro upgrade is what caused the issue.

Not sure if mgcb itself works either, haven’t tried that yet.

Edit: It seems as though mgcb does work.

Develop version of Pipeline Tool is broken on Linux… for the past 24 days X.X, this fixes it:

(and yes, I did submit the PR on the day it broke)

And how do you suppose I install this? I installed MonoGame using apt-get.

Wait, how did you do that, MG does not support debian packaging. What package did you use?

On a side note, now that I look at your error I see that its from 3.6 stable, not the dev build so my previous comment was not useful, tho the current dev branch Pipeline Tool does crash with the same error.

Also please post the full error.

That is the full error. It only prints that when I run the executable. As proof:

Edit: Guess I derped when I said I used apt-get to install it. I actually can’t remember how I installed it. Possibly through the website.

Do: “sudo apt-get install gtk-sharp3”, I’m guessing you skipped over dependency.

That fixed her right up. Thank you!