Content Pipeline

According to the documentation, both on this site and on GitHub, there is supposed to be a content compiler
( and )
However, despite my best efforts to find said tools, I can not find them.

Could I get some info on them, possibly where to get them, and possibly request to the MonoGame staff to make this more obvious?

Also, installing XNA is not an option, I run Windows 8.1, and installing VS2010 and other tools is out of the question due to various reasons.

I am running MonoGame 3.2, just updated today.


Things have been moving fast and MGCB and the Pipeline GUI tool are newer than the MonoGame 3.2 release.

To use the new pipeline stuff you have to install one of the nightly development builds.

Ah, thanks a ton!

Keep up the great work, MonoGame is awesome!

1 Like

And effects is working with new content pipeline ? I get error with DllNotFoundException “Unable to load DLL libmojoshader_64.dll”

Yes it works (on Windows only for now).

The missing DLL message suggests that maybe you didn’t update the submodule in Git. The libmojoshader_64.dll was moved and updated recently and it probably won’t be found if the submodule is out of date.

Also note the content pipeline is now 64bit only and any pipeline extensions should be built as 64bit or Any CPU to be compatible with it.

I updated submodules but didnt found updated version of libmojoshader_64 inside(old 160kb only), recompiled MonoGameContentProcessors also dont contains it. In final version of monogame this would be fixed ?

DllNotFoundException “Unable to load DLL libmojoshader_64.dll”

A lot of time has passed and the problem still persists. I am trying to build an fx effect file on Windows and use it on Linux (as I understand that is the only way to do it). After defeating a lot of dll problems I am still stuck on this one. I used the official installer (which I thought is actually supposed to automate things) and the mentioned dll is present in the MSBuild/MonoGame/v3.0/Tools. I am forced to ask this question since the provided documentation is not helpful at all and suggests that installing everything using the installer will do the trick. Is there a guide which helps with resolving the dll issues?

I tried rebuilding the project myself. I used the development branch but unfortunately that didn’t solve my problem:

  • on Linux development branch the Pipeline tool could not be launched at all and failed with the following error:

      System.ArgumentException: 'MonoGame.Tools.Pipeline.Icons.settings.png' is not a valid resource name of assembly 'Pipeline, Version=, Culture=neutral, PublicKeyToken=null'.

(That is all right since I understand that I would not be able to build the effect file on Linux anyway).

  • on Windows development brach the Pipeline tool can be launched but fails with the following error while building the effect file:

      System.DllNotFoundException: Unable to load DLL 'libmojoshader_64.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

(So nothing changed and the same error persists).

  • I encountered the same error when trying to launch a build from the master branch on Windows

Guys could someone clearly state if this is something that I am doing wrong or if Monogame is simply broken and after all this time still doesn’t support shaders? I remember that this is what stopped me from using it about a year ago. Everything else works perfectly but this one thing is a major obstacle on my way to actually using it.