ContentLoadException after updating MonoGame to development build

Hey guys,

I tried updating MonoGame to the latest dev build from 3.5 last night in an attempt to solve some display issues I’ve had on my macbooks retina screen.

After doing this however, i started getting a ContentLoadExceptions when trying to load textures when I build my project.

Microsoft.Xna.Framework.Content.ContentLoadException: The content file was not found.

Does anyone know why this might be happening?

I’m on MacOSX using Xamarin Studio

Can you provide some more detail and check the inner exception? Most often the issue when getting that exception is that the xnb is not at the right location.

Hey Jjagg. I won’t be able to give more details until I get home, but yeah I do remember it couldnt find the xmb for that png. Do I need to download the latest Content Pipeline tool as well?

It’s probably a good idea to use the same version of the Content Pipeline and the runtime, but I think most binary formats haven’t really changed (except for Effect files). Anyway, that’s probably not related and the inner exception will probably help you figure it out.

1 Like

Cool. Thanks for the advice!

I’ve been poking around withe the inner exception, and its a System.IO.FileNotFoundException (Could not find file"/Users/Tom/Dev/game/Cemetery/Cemetery/bin/Debug/"), but that xnb definitely exists at that directory. Any other ideas what it might be?

Nevermind, I immediately worked it out. I was still using .png on the filename. I feel very silly right now