Could not load file or assembly 'MonoMac' or one of its dependencies

Hello, I am attempting to follow along the Games from Scratch tutorial, basically I have installed the universal Mono dev kit, Monogame 3.4, and Xamarin studio 5.10 on OSX 10.11.1, but when I try to run the basic Xamarin.Mac Monogame template I get the following in “Application Output”:

hastebin of output

Basically its "Could not load file or assembly ‘MonoMac.’

I have attempted editing my references, and I have tried adding a MonoMac assembly (which is suspiciously version, but when I do that I get several errors stating that many of the definitions are already defined, making me believe this is a naming issue.

Any help is greatly appreciated!

I tried uninstalling Mono, Xamarin Studio, and Monogame and then reinstalling them in that order just to make sure I had everything up to date, but that did not help.

You shouldn’t need MonoMac as I believe that’s been deprecated with the latest versions of everything - all those references should now be in Xamarin.iOS.

Do you know what it’s looking for in MonoMac? If there are any MonoTouch references in there to things like ‘using MonoTouch.Foundation’ change them to ‘using Foundation’ etc…

We are in the process of migrating MonoGame onto the Unified Mac API: