d3dcompiler in content pipeline effect

Playing with the 3.5 content pipeline and tried adding an effect file. When the content pipeline tries to build the fx file it fails with Unable to load DLL d3dcompiler_43.dll.
I vaguely remember this problem and solving it using /dx11 in the 2mgfx command line. How do you solve this in the content pipeline? Also 43 is pretty old so why try and link that version? Tried using vs and ps 5_0 but still wants the old dll
This is just for a standard Windows DirectX project.

Because it works and is easily redistributed. Newer versions are tied to the Windows 8 SDK and would require developers to install it which sort of sucks. Even newer versions come with the DX12 SDK… which doesn’t work on Windows 7.

Probably missing the DX runtime on your system:


That is all I can think of right now.

Thanks Tom. That works. Had considered it but thought things had moved on and ddin’t want to install a n old SDK on a new machine.

It isn’t an old SDK… it is the runtime bits needed to run most DX9/10/11 games. Most games do a silent install of this during their installation.

Well with my old Windows 7 32 bit machine I had to rebuild 2mgfx for 32 bit. Finally got a nice new Windows 10 64 bit machine and didn’t want to pollute it with software from 2011. How expectations change ::smiley: