Development Build Issue? (3/7/2016)

So I have noticed this a bit back when my internet went down tested a more recent build than the one I was using.

I have compared this in the development builds WindowsGL, Windows(DX), AND Linux… The Click locations on the
Windows (using a standard game window) do not accurately show in the window. If you have something tell you what the
location is that is being click and the window is small in the middle of your screen itll give you coordinates like 400-700… so its giving screen coordinates…

Im not sure if this was intentional or a bug(If intentional is there a new way of targetting the mouse location directly inside the window only?)

I’ve updated my version yesterday and Mouse.GetState().X/Y returns the right value every time for me

Windows DX version

It’s always relative to the top left corner, i tried with really small windows (100x100). Can you tell us more about when the issue occurs? How small must the window be?

The windows size wasnt really relevant, I resized it over and over(and this is based on a pull ive done today.)

The thing is it isnt grabbing the screen coordinates rather than the Windows coordinates… Ive resized and no effect it literally only says 0,0 in the top left of my screen, which is only accurate in fullscreen mode.

@Damien_James_Gibson - What platform is this on? Is it running on DX or OpenGL?

I tried both. Its just with your development builds dont seem to have correct mouse coordinates… when I uninstalled the latest dev builds- reinstalled the 3.4, the coords are accurate again…

They only have the problem with the new ones as far as Ive tested.

I can recreate the issue on WindowsGL, but not Windows (DirectX). Windows (DirectX) correctly reports 0,0 when the mouse is at the top left of the window client area, and negative to the left or top of that position. WindowsGL does appear to report in screen coordinates, regardless of the game being in windowed mode.

I feel so blind…

The fix has now been merged into the develop branch.

cool, tried it out i dont seem to have the problem anymore :smiley: