Error when running MonoGame Extended sample demos in Visual Studio

I want to get the hang of MonoGame Extended by referring to their samples (GitHub - craftworkgames/MonoGame.Extended-samples) but when I tried to run them in Visual Studio it would not recognize the Xna or MonoGame Extended class references

I also got this error per each project in the solution

It did come with MonoGame 3.8 DesktopGL as a NuGet package but the Readme for the demos says this

However I already had MonoGame 3.6 installed and that didn’t take care of the issue.

Let me know if this is a recognizable issue with a fixable solution!

Hi ReadrX,

I followed one tutorial of a simple game using monogame 3.8 and Monogame Extended on Mac.

I needed to put extended references in my csproj file to use monogame extendend.

You can check my code here rpg/rpg.csproj at master · educrod/rpg · GitHub

Hope it helps.

Fixed it! I had a space in the name of my user folder so deleted my Windows account and got a new one (not a big deal in my case since I only use this PC for development purposes with everything backed on GitHub) without the space because in the username because Microsoft doesn’t make it easy. After going through that it seems to work.

1 Like