Errors while installing mgcb-editor

When I run this command :

dotnet tool install --global dotnet-mgcb-editor

These errors are shown :

The tool package could not be restored.
Tool 'dotnet-mgcb-editor' failed to install. This failure may have been caused by:

* You are attempting to install a preview release and did not use the --version option to specify the version.
* A package by this name was found, but it was not a .NET tool.
* The required NuGet feed cannot be accessed, perhaps because of an Internet connection problem.
* You mistyped the name of the tool.

For more reasons, including package naming enforcement, visit

This is the second time I am installing mgcb-editor. Earlier when I tried to install it, there were no error during the install, but for some reason mgcb editor was not starting…
So I uninstalled it, in order to reinstall it again.
But now it gives me these errors.

Any Ideas?

As the error message says, specify a --version

I’m currently using I don’t know if that’s the newest version, but I know it works.

So… to summarize, in your nuget package manager console type

dotnet tool install --global dotnet-mgcb-editor --version

@ikanreed thanks for the reply but it doesn’t work either way…
I already tried specifying the version, but the same error pops up in the console.

Also there are no internet connection problems.

Any other ideas?

What do you get when you run

dotnot tool list --global


@ikanreed Nothing…

Alright so after a quick restart, mgcb-editor is now installed.
But there still the same problem i.e. it never runs…
Even after clicking the mgcb-editor in the start menu…

You can find where the actual binary lives by running “where mgcb-editor” which may help with figuring out what’s wrong

@ikanreed Sorry For late response.


Not sure if this will help… Since you’re running Windows, have you checked the Event Logs?

@pherbeas no i haven’t, can you help on how to do it.

Click “Start” and type “Event”. Event Viewer is what you are looking for. I’m doing this from memory… “Windows Logs | Application” or “Windows Logs | System”. Not sure if anything will be there.

One other thing you can do is open file explorer and browse to “C:\Users\DevGa_me.dotnet\tools” and double click the file.

I did ran it from the Users Folder its still the same ( A cmd window appears and then vanishes ).
There was nothing in the event viewer as well.

Does this output anything:
mgcb-editor /?

Also, try this:

And try this:
Click Start and type monogame

In the screenshot i sent before, i ran that command but no success.
The editor does start (it shows up in the task manager) but without any visual thing, it crashes.
Same when i run the mgcb editor from the start menu.

Try right clicking on it and say “Run as Adminstrator”

Nothing, it opens and crashes before anything appears on screen

Have you tried launching it from VS?

Did that, but the same thing happens.
It appears only in the task manager and then crashes.

1 Like

Anything in Event Viewer?

Forgot what it is called but you can rebuild your .NET thingy