Exported FBX not working in Monogame

I have a problem with FBX files exported from SketchUp in Monogame. They work well in XNA.

For example, this simple model exported from SketchUp:
When I try to load it, an error appears: “could not load asset as non-content file” even though it is set as a content file like all other content files.

I even tried to convert this FBX to newer format supported by Monogame (using Autodesk FBX Converter x64 2013):

And this converted model seems to load right by Monogame, but is invisible in game.

Can someone please check this model and explain how to fix it? It appears with all FBX models exported by SketchUp.

You can’t directly import FBX, you first have to use MonoGame Pipeline Tool to convert it to xnb.

The documentation page should explain it:

PS. XNA also did this, except it had Content Projects instead of Pipeline Tool for conversion.

Yes of course, the models where converted to xnb. Actually, I tried both converting via XNA and Monogame Pipeline Tool but results where the same.

Since I don’t know what problem you are having, here, enjoy the video, includes both the conversion and deploying in game:

Note 1: After using Autodesk FBX Converter, I used Blender as well because texture paths get messed up… I think it’s just with FBX Converter on Linux, plus the newest version for Linux is 2011.3…

Note 2: Set all xnb files to Build Action: “Content”, Copy Action “Copy If Newer” if you are not using the mgcb file included in project

Thank you very much, perhaps it is due to textures. I’ll try to fix this issue with Blender.
I assume that, that once you deployed this model in game it was actually visible for you?


Note 3: Sketch up exports ascii fbx, that’s why I had to use FBX Converter before blender, blender only supports importing binary fbx files