[Extended.Tiled] Another issue with the importer

Hello again,
So I was able to create a project using MonoGame extended tiled. I was able to get a map showing and even a camera moving around, but, I went to continue working on it only to find that the importer has suddenly stopped working.

It says the processor/importer is missing, even though it was working perfectly fine beforehand. I tried making an entirely new project, installing all the NuGet stuff, and trying to import the correct dlls, but to no avail.

I have spend hours looking at the issues on GitHub, and other posts on the forum, but nothing seems to work. I’m using MonoGame for my final year project and would love to continue using it, but at this point it seems more issue than worth.

Sorry for rant,
I would greatly appreciate any help (again :confused: )

Hello @SilenceOfTheLambdas

Are you using a setup similar to what is found here? https://github.com/craftworkgames/MonoGame.Extended-samples

Yea I got similar errors when playing around with it a while back. It had something to do with removing the reference in NuGet and then re-adding it… it breaks a bunch of stuff, maybe?

I ended up just writing my own file parser to just bring in the stuff I wanted.

I wouldn’t write off MonoGame entirely because a third party library (which also has a ton of other great, working stuff) had a bug in it. Ultimately it’s up to you and what you wanna accomplish though :slight_smile:

Worst case, there’s always PICO-8!

1 Like

If you just clone the repository in it’s state now, it will work

I’m not using a layout like that one; I think I’ve seen this previously and tried it, but I’ll give it a go again.

I’m still quite new to how this all works, could you explain how I could make a project using the sources?
I’ve cloned both monogame and monogame extended repo, I assume I add all of both to a solution?

It might not be finding the MonoGame.Extended DLLs. Try placing them in the same folder as the MonoGame content builder. (mcgb.exe)

Unfortunately, this didn’t work :frowning.
I appreciate the effort though.

UPDATE: cloned the repo from here and opened the solution up, it seems to be working correctly.

Well, I tried replacing the content from the example with my own assets (a Tiled map), and it fails again now. Still saying there is no importer.

Yes, the problem is most likely your .mgcb file needs to find the .dll but the .dll is not found. The .dll is pulled in when you restore via NuGet so you can just change the .mgcb to point to the .dll sitting in your cache. However, the samples project uses a NuGet.config to change where the cache is and then uses this location in the .mgcb file.

Btw, this is all necessary because .mgcb files don’t understand NuGet references. Perhaps it would be a good addition for the MonoGame team to have NuGet references syntax for the .mgcb files?