Game doesn't run in Debug mode with new Nvidia drivers

I have an Alienware 15 R3 and am on Nvidia driver v391.25 with Windows 10 64-bit, the latest BIOS version, and MonoGame on a DesktopGL project. If I update to a newer driver version, I cannot run Debug builds at all for some reason. In VS, the game builds, but the graphics device doesn’t seem to initialize and the program exits before I can even see the game window. Furthermore, running the .exe of the Debug build produces the same result.

However, Release builds do work, and I’m not really sure why. Is anyone else having a similar problem or does someone have insight into what might be going on?

Yes. I’ve had similar problems with Win 10 64-bit and Nvidia drivers and so have others. I have yet to figure out a solution and I’ve tried everything (fresh installs of the OS, reinstall monogame, update drivers, etc…)

I’ve got one work around but it is hit and miss for me. I can start the game in debug, GPU doesn’t initialize, I hit stop, and start in debug quickly again… and sometimes it initializes. Really annoying but if I keep attempting to start it in debug, it works occasionally.

I don’t have time to search for all the other posts others have reported but here are a few: