Game will not open under any circumstances.

When running dotnet run in my console (I’m using VSCode), the game will not open. It’s opened multiple times before, one just a few minutes ago, but now, despite undoing every change I’ve made in the last few minutes, it still refuses to open. There are no errors in console.

I’m not new to game development but I’m new to MonoGame/XNA and still relatively new to C# and .NET so I’ve probably done something stupid. I’m willing to provide any code needed for help, I just don’t know what’s useful :sweat_smile:

To be sure: have you tried restaring your pc?

Yes, twice.

Could be missing content. Check your Content.Load(Y). Paths, names, included in pipeline, etc.

I’ll check again, but I’m pretty sure it’s not.

As a debugging test, I put a line that logs Hello World in my Program class before it starts the game - this logger doesn’t seem to be triggering, so it seems to not even be running the code. Is there any chance it could be a .NET error I’m missing?

EDIT: When reopening the code the next morning, I do get two CS0169 warnings about unused class fields so it’s definitely compiling something…

EDIT #2: Thought I had managed to fix it by excluding the folder from my antivirus checks, but apparently not (it flagged an error earlier, having blocked a “suspicious action” from the .exe generated from a previous run before this bug occured).

Solved! It turns out that a lot of errors coming from a library I was using (Monocle by Maddy Thornton) were causing some issues so once fixing those I seem to be in the clear.