GeonBit.UI: UI extension for MonoGame

I see… anyway, I do understand how the content pipeline works in theory, in fact it’s very simple, you have ‘importers’ that convert sources into some kinda binaries you can use in the engine, and that mgcb tool is just a tool to automate the batch processing of the assets, however, in practice it’s a different beast. I can’t for the love of mine get it to process the GeonBit UI assets, spritefonts fail with index outta bounds, effects fail with some directx dependency problems, some xmls also fail with “element ‘B’ is required”, whatever that means. I’m giving @prime31’s Nez another try. The official FNA repos won’t work for me so I’m setting it up by hand, but at least it officially supports FNA.

Hi @Alan,

Sorry for the late replay, wasn’t here lately. Which MonoGame are you using? And are you using the NuGet package and followed the instructions in the readme?

BTW, if you work on Linux there’s a known issue to build effects (not related to GeonBit, its in MonoGame), so you need to use the pre-compiled effects.

Also, if you download the entire git and just build it as an exe instead of a lib, does it work for you? The project from the git should compile as an exe and run a demo program.

Thanks,

Hi, no apology necessary. I’ve tried both in MG3.5.1 and the latest 3.6, none of them could build the contents; 3.6 fails building spritefonts with unexpected failure. I did download the entire git and tried to build, the solution, as well as the MG36 project to no avail. I managed to get it working in FNA though, just without the content pipeline of course. So, no worries, I’m not really planning to use MonoGame anytime soon anyway. But boy, every time I’ve tried it, the experience was never smooth, and I still don’t know how some things work, for example I managed to get the latest Nez running in the latest FNA but it was a bit of hit and miss since I really don’t know how the whole shebang works, I’ve even opened the csprojs and sln to take a look, but some things, like for example when I try to reproduce the FNATester from scratch I get very different results, even adding the exact same references it still won’t find stuff like Content for example, so these things I can only describe as black magic :).

I don’t know man I never had these kind of problems with MonoGame before… sounds like something is broken, are you using Windows with visual studio? I think MG work best on vs/Windows.

Yes, I am using VS2017, but no problem man, I’m going to give it another try next weekend. Thanks for your support so far :slight_smile:

On the git page, it mentions

It is currently not designed for keyboard-only / joystick input (e.g. it doesn’t support tab navigating etc.)

Are there any plans on supporting that form of input? Is there any easy way to disable mouse input as it is?

sorry but not at the moment. it will require some coding work to get what you want. If you’re up to the challenge I can guide you with some hints of what to change and where, send me an email or pm if you’re interested.

This is impressive. Is there a tutorial on using this UI with a touch interface?

Hi @Mathetis, I’ll soon release a version that will address touch input.
@thera next version will allow finer control in input methods, so it might help you too. but I’m not sure it will be enough for full joystick / gamepad support, unless you want to use them to emulate mouse.

Will update soon when its ready.

Thanks :slight_smile:

@Mathetis here’s the promised update - I released a new version where you can override the class that provide GeonBit.UI mouse-based input, and emulate mouse events using touch input.

The rest of the system will act the same, only with touch instead of mouse.

It will require some implementation though, you’ll have to implement this API:

Let me know if something is unclear… cheers :slight_smile:

1 Like