Getting (re)started with Windows Phone 8 on VS2013 express

Got a new dev box and I’m trying to update the way I do things to the latest Monogame recommendations.

I’ve installed VS2013 Express, and also the latest Monogame version for Windows. I started off with the version linked on the downloads page, only to get the following error when I tried to create a Windows Phone 8 game from the template:

I then tried installing the latest dev version from here:!ossgocr

Trying to create a WP8 game from the template gave me this error:

Trying to create a WP8.1 game from the template gave me this error:

Anyone have any ideas how to fix this?

I would recommend using Visual Studio Community 2013 instead of Express versions. It’s pretty much VS Pro version and it’s for free too.

Do you actually have a working dev environment based on VS Community 2013? I read on another thread on here that you needed the desktop version of Express to get the templates working, and I’d rather avoid having to uninstall and re-install everything if I don’t have to…

Well I have VS 2013 Ultimate and everything is working fine, but even if you have to install VS 2013 Express, because of some bug, I would recommend you using Community anyway. It’s just better Visual Studio. The problem behind your errors is that you can not do WP8 development with VS2013 Windows Desktop Express version. You would have to install Visual Studio Express 2013 for Windows.

But really don’t do that if you can use VS 2013 Community.

Okay, doing slightly better with VS 2013 Community:

Started out with the standard download link again - an empty WP8 monogame project created and built OK, but then locked up before hitting the cornflower blue screen when run on device - all I got was a plain black screen.

Grabbing the latest development build, I got the same error as yesterday when trying to create a new WP8 monogame project - however, the WP8.1 template created a project that built and ran successfully.