How avoid transparency when color is violet?

Hello, when the image below is drawn, the purple part becomes transparent. Any ideas how to fix that?



I believe the issue here is how the mgcb editor compiles content into .xna files. The purple color is the “color key” that allows the empty part of the image to not be drawn. You could change “color key enabled” to false, but I don’t know if you need that image to have transparency: you could just choose another color that’s not on you color spectrum.