How do I get Monogame working on Monodevelop 4.01, Windows 7?

Hi everyone. I’ve downloaded Monogame 3.3 from and run protobuild.exe. It generates a bunch of .sln and .csprog files, which I understand to be Monodevelop solution and project files, but I’m not sure what to do after that.

Note that I haven’t spent a lot of time with Monodevelop, only a few days playing around with Unity (which Monodevelop was bundled with) so I may not be familiar with what may seem obvious to other devs.

I also read that an older version (3.2) could be installed via the Add-in manager, but that package doesn’t seem to be available anymore.

You can open those solution/project files in either Monodevelop or Visual studio - just pick the one that matches your platform (windows 7 in this case, though I’m not familiar with the exact file list) and open it - from there, build as you would any other project, and you’ll have DLLs.

I you’re not planning to actively alter the source code and are trying to make projects with MonoGame, it might be better to run the installer from the website, which installs project templates, content builder tool, and libraries in the GAC.

Thanks. I’m looking to just learn how to use MonoGame to make games. and see whether it’s something I’d like to continue using. (In fact, I’ve been exploring other frameworks like HaxeFlixel and Unity this month.)

It’d be geate if I could ‘integrate’ MonoGame with MonoDevelop, so that when I create a new solution, the option to create a MonoGame project appears. All the tutorials I’ve seen use this as the starting point. But there doesn’t seem to be an installer available for MonoDevelop right now; the website states “NOTE: The new addins for MonoDevelop/XamarinStudio are coming soon! For now build from source for Linux and Mac.” (Older versions also don’t seem to be available.) There’s one for Visual Studio, but the Visual Studio Community installer requires 8 GB on my OS partition (even if I set the install directory elsewhere), that’s difficult for me to free up.

Building MonoGame-3.3\ProjectTemplates\MonoDevelop\MonoDevelop.MonoGame\MonoDevelop.MonoGame.sln produces MonoDevelop.MonoGame.dll (in addition to the already present MonoDevelop.Core.dll). There are other .sln files in the distribution, but some of them like MonoDevelop.MonoGameContent.Win.sln and MonoGameContentProcessors.sln give errors when I build them, and at this point I don’t know what .dlls I need, and what I need to do with them after that.

I’d greatly appreciate it if you (or someone else) could help me get to the point where I can start following the tutorials and using the MonoGame API. If v3.3 hasn’t introduced drastic changes, I’m fine with using an older version for now. (I’m still exploring options at this stage, ultimately may not go with MonoGame) I understand that there were convenient NuGet installation packages for older versions but I can’t find them, if someone could point me to them or send me the files, that’d be great too.

If you’re looking to use monogame, then you’re definitely better off using the installer. The behaviour you’ve described is exactly what the installer is meant to set up for you - rebuilding from source is only for when you want to modify and contribute to that source (EDIT: or you want to use/test unreleased, bleeding edge features), as even using the DLLs directly is easier via NuGet (assuming those are up to date).

Sounds like you’re ending up in the add-ins page rather than the main download page - see Note that “MonoDevelop” became “Xamarin Stduio” after a certain version, so the two are largely synonymous (except where Unity is concerned, of course). This page will ask for a little information, but down download the installer.

Once installed, you may need to run the MonoGame installer again in order to get the project templates loaded onto Xamarin, since you installed the former before the latter.

I meant there doesn’t seem to be a MonoGame installer for the MonoDevelop/Xamarin IDE right now. (You linked to the download page for Xamarin Studio.) The MonoGame download page only has an installer for Visual Studio. The “latest releases via NuGet” links are all to pages for v3.2.x packages which are no longer listed, and which also don’t show up on MonoDevelop’s add-in manager gallery.

Anyways, I bit the bullet and freed up the needed space for Visual Studio. (Had to muck around with permissions and move OS folders off partition using symbolic links, hopefully that didn’t break anything.) The MonoGame installer for VS worked fine.

Well, I’m at least glad to hear it worked, if more than a little embarrassed by the misunderstanding on my part. Apologies and jubilations!