How to enable texture filtering for SpriteBatch?

When i try to draw a simple texture with SpriteBatch, the texture is not filtered. My code is pretty simple:

        protected override void LoadContent()
            _spriteBatch = new SpriteBatch(GraphicsDevice);
            _texture = Content.Load<Texture2D>("bin/Windows/tr");

        protected override void Draw(GameTime gameTime)

            _spriteBatch.Draw(_texture, new Vector2(0, 0), null, Color.White, 0, Vector2.Zero, 0.1f, SpriteEffects.None, 0);


As you can see, the white moon and star looks pretty jagged

Here it is close up

How do i filter the texture so it does not look jagged?

Uuuuh… Use a sprite where it’s smooth?

There is a SamplerState parameter for SpriteBatch.Begin - but it should be set to linear by default, but it wouldn’t help in your case. Sampling cannot make your texture suddenly be more detailed.

What you really want is just a higher resolution texture in the first place, looks like you are supplying a low resolution to it - or your output is just a low resolution. There is only so much pixels. Bigger Textures help with that as well, as it will use a properly scaled MipMap Level then