How to get the Monogame Pipeline to work?

When I run my build I keep getting this error:
Error The command ““C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\MGCB.exe” /@:”" /platform:Windows /outputDir:“C:\Users\Lionel\Documents\Visual Studio 2015\Projects\PlatformGame\PlatformGame\Content\bin\Windows” /intermediateDir:“C:\Users\Lionel\Documents\Visual Studio 2015\Projects\PlatformGame\PlatformGame\Content\obj\Windows” /quiet" exited with code -532462766.

I have 2 projects in my solution with MCGB.exe in each. Am using VS2015 Community. Everything was working fine because I was loading the raw content files png etc. I then did an update and everything fell apart.

Have now stripped down the pipeline build to one background.png file and get a clean compile. As I add content files, I can’t seem to get a consistent build of the content. I’m trying to find out which content gives the pipeline trouble. When I do a pipeline rebuild it skips over files inconsistently.

I have lots of content and don’t want to be copying from previous projects. Is there some definitive documentation as to how the pipeline should work?

What update? Have you tried on a different machine?

Actually, I was trying to find the GamerServicesComponent so I uninstalled MonoGame and reinstalled everything to 3.4.

After much trial and error, I found out that the pipeline gives that error message whenever it encounters a file it cannot process i.e. thumbs. If one has a folder of png files, windows creates thumbs file to display them and I constantly have to work with display all files to remove these. Also it seems to help to have Build Action of the pipeline file to be set to MonoGameContentReference.

One of the content files it has problems with is a spritefont. It can’t load the font. I have to educate myself on this.

Sorry, I don’t understand what the problem is. You have to be more specific.

nkast thank you. The problem is that the pipeline does not behave consistently.
There are no diagnostics when it encounters a file it cannot handle for some reason. Example, when I tried to load kootenay,spritefont it just said could not load kootenay font.After much searching I found that Microsoft no longer includes that font in windows 10. I found the font and installed it and the pipeline now works until the next file it can’t handle.

The pipeline seems to skip over files it has already completed when one builds again in the pipeline. If you don’t delete these files the vs compiler gives the above error. I have not found a way to remove the second execution of the pipeline. I would prefer to run it manually.

I want the pipeline to do a complete build each time and not skip any files. How do I do this?


From my view, It’s not the pipeline here with no consistensy…

From the Menu/Build/“Rebuild”. The “Build” command skip assets you allready build.

Give a try to the latest develop build of monogame to see if this solve the problem with that error, at “Development Builds” ,

After much experimenting, I’m beginning to understand how I can get my content created.

The inconsistency comes from the 2 executions of the pipeline. Using the menu it is easy to control the execution build or rebuild as suggested. But what does the automatic execution of the pipeline by vs2015 do?

Is there a way of disabling the auto execution?


Finally got the pipeline working.
The error was caused by the build action must be set to MonoGameContentReference as explained in this issue
MonoGame Issue 3360

Most annoying issue is that the pipeline hangs when it encounters a file it cannot handle requiring to go back to the content folder and remove the offending file. A message would be nice.

Would much prefer that the pipeline no execute automatically in the build. I found that I was collecting assets from different projects and had to run the pipeline several times. Sometimes after the automatic execution would not work although the xnb’s were properly created.

A minor issue is that when you doubleclick on the mcgb file it brings up the last project and not the one clicked on. If you happen to have files all named content.mgcb in different projects you don’t know which project you’re working on and get the message that the files are not in the directory do you want to copy them.

Otherwise the pipeline works great.

Hope this helps someone else.