how to use dev version to fix 2017 templates issue

I am sorry to have to ask but until 3.6.1 is available I’m stuck and am trying to follow what hints I have found.
The system Im working on has a clean install of VS 2017 community and I attemped to start the monogame 3.6.1 install but got the greyed out 2017 templates issue so stopped.
I thought I could just download the latest build but was dumped into github so proceeded with a clone.
So far I have cloned the dev version into my local gitrep.
I tried to find a installer for windows but failed.
Now Im stuck.

What link did you follow?
Check under Development Builds on the downloads page. There are downloads for all platforms generated by the build server from the develop branch.

1 Like

I did use that link and have done it again just to be sure.
The install does not include the templates for 2017.
The option to include it is greyed out.
I do not have VS 2015 installed.

As my computer has seen visual studio 2010, 2013, 2015, 2017, through years, all of the options are available with the MG installer.
Have you installed vs2017 with the development desktop .Net c# options ?

Yes and just checked the option is still ticked.
I just went through creating a test windows desktop c# app which worked ok.
I retried the Monogame install and now the templates are available.
Thank you for the help.
Onwards and upwards I go.

1 Like

It may be related to the very first monogame project created, triggering/creating templates then. Something to note and not to forget for my next computer :wink: