I can't get monogame to install on Visual Studio 2017

It’s been a while since I’ve used it, and since then I’ve switched to a Windows 10 PC. I just installed VS 2017 community version and made sure I also installed all the right tools.

For some reason, when I open the installer, all the options for any version of VS are greyed out (I can only select the “create desktop shortcut” option), and when I try installing it anyway, Monogame doesn’t appear as a project option in VS.

What am I doing wrong? With 2015, it just installed and worked. v_v

This is what I’m getting on the install wizard, and I definitely have VS 2017 installed.

Hey @BisectedBrioche! Please try the development build. The 3.6 release is over a year old and it did not yet support VS 2017.

I haven’t heard this before and it definitely will not solve this issue. That said, if you can install the templates for a previous version of VS you can manually copy them over to get them working with VS2017.

I don’t understand this issue [Never had it over more than 50 installs on fresh and long use systems], but did you try running the installer as admin or did you just double click it? and is your windows installation fully up to date?

Pretty sure he is using the dev build… 3.7+

Oops, I missed that.

1 Like

https://github.com/MonoGame/MonoGame/issues/4612#issuecomment-320479025 ??


Yes, she is (I’ve tried all the builds at this point.

This seems to have fixed it!

I added the folder, ran the installer again; it let me select VS 2017, and now all the templates are present and correct. Thanks!

1 Like

This was ticked by default but still not working for me.
IT randomly does and does not work.