Improving poor model quality rendering

Complete newbie here but I have a number of 3D models (FBX) that I have imported into MonoGame.

The problem I am finding is that the output quality of the models when rendered by MonoGame is extremely poor compared to how they look in Blender and in particular Visual Studio.

To provide an example here is the output of the VS editor:

And here is the model as shown by MonoGame.

I have the lighting turned right down and I am using the BasicEffects shader. I assume I am doing something wrong or perhaps need to use a different PixelShader?

Any guidance sincerely appreciated.

Anyone willing to provide any input? Would sincerely appreciate any guidance…

I’m no expert, but it looks to me like you’re only getting ambient light, since there’s no shading.

You say you’ve turned the lighting right down, that might be what’s causing it.

Much appreciated Avan,

I am using the following code to light the garment (where _Variable is a predefined customizable value)

foreach (ModelMesh mesh in currentModel.Meshes)

    foreach (BasicEffect effect in mesh.Effects)
        effect.World = GetWorld();
        effect.View = _ViewMatrix;
        effect.Projection = _ProjectionMatrix;
        effect.TextureEnabled = true;
        effect.LightingEnabled = _LightingEnabled;

        if (_GlobalSpecularColor != null)
            effect.SpecularColor = _GlobalSpecularColor.Value;

        if (_GlobalSpecularPower != null)
            effect.SpecularPower = _GlobalSpecularPower.Value;

        if (_LightingEnabled)
            effect.AmbientLightColor = _AmbientColor;
            effect.DirectionalLight0.Direction = _DirectionLight0;
            effect.DirectionalLight0.DiffuseColor = _DiffuseColorLight0;
            effect.DirectionalLight0.SpecularColor = _SpecularColorLight0;
            effect.DirectionalLight0.Enabled = true;

            effect.DirectionalLight1.Direction = _DirectionLight1;
            effect.DirectionalLight1.DiffuseColor = _DiffuseColorLight1;
            effect.DirectionalLight1.SpecularColor = _SpecularColorLight1;
            effect.DirectionalLight1.Enabled = true;

            effect.DirectionalLight2.Direction = _DirectionLight2;
            effect.DirectionalLight2.DiffuseColor = _DiffuseColorLight2;
            effect.DirectionalLight2.SpecularColor = _SpecularColorLight2;
            effect.DirectionalLight2.Enabled = true;


I would suggest you try these tutorials on Shaders (XNA but work in MonoGame with minimal to no changes)

Following that try looking at Deferred rendering.

This will allow you to render your model with the shadow effects you are seeing in the VS render

Finally worked it out! So for anyone curious it was the EmissiveColor of the BasicEffect shader that was causing the problem as by default it was set to 0.8.