Is MonoGame currently impossible to install on MacOS? (edit: installed! But the Pipeline Tool won't start)


TL;DR: I, too, have been trying to get MonoGame to work on my Mac with no success. (Mojave 10.14.6)

First I tried following the official installation instructions, which as has been pointed out lead to installing incompatible versions of MonoGame and Visual Studio.

Then I tried downgrading to Visual Studio 2017, and was finally able to create a project (since the project templates finally showed up). However, I couldn’t get any project to compile, because of the same error as this person, which is apparently because Visual Studio 2019 (so I assume 2017 too) does not support Mono 6.0.

So I downgraded to Mono, and now get

Error MM0001: This version of Xamarin.Mac requires Mono (the current Mono version is

Conclusion: unless at least one of my sources is incorrect, there exists no compatible combination of MonoGame + Visual Studio for Mac + Mono that is currently available.

Am I missing something, or would that be correct? I would love to use MonoGame, but I have already spent a couple days trying to install it unsuccessfully, and would much rather believe it’s just me being stupid than assume that it is actually currently impossible to install.
Any help is much appreciated!

Which version of MonoGame are you trying to install? I believe the develop branch is currently in the middle of migrating to .NET Standard and a new build system, and the instructions haven’t been updated yet.

Oh, is that so? That’s great news to hear! :slight_smile: thanks for the info!
I was trying to install MonoGame 3.7.1, but I actually have an update:

I tried opening the project created with the Visual Studio 2017 + Mono combo in a system with Visual Studio 2019 + Mono 6.0, and it worked, so I’m guessing the compatibility issues were not actually the problem…? In other words, the newest versions seem to work fine, it’s just that projects can’t be created (one could argue that constitutes “not working”, but… there was a viable workaround, so hooray).

Now, then, the problem is that the Pipeline Tool simply won’t open. It instantly crashes upon start up. Running it from the terminal gives LSOpenURLsWithRole() failed with error -10810 for the file /Applications/
, if that’s of any help.

Is there anything that can be done? I’m using this Pipeline Tool version (the stand alone installer in the Downloads page) in macOS Mojave 10.14.6. Maybe trying and downloading an older version, if I could find those somewhere?
(maybe I should rename the thread…?)

“macOS Mojave 10.14.6 + vs for mac 2017 + MonoFramework 5.18 + MonoGame 3.7.1 + Pipeline.MacOS” Development environment test passed. Do not use vs for mac 2019 and close auto update and do not update “visual studio for mac 8.x”!

Compile need setting Visual Studio > Preferences > Projects > .Net Runtimes > mono 5.18.x is default