Is this just a problem with my Content directory or something?

Hi guys, I’ve been trying to update an older XNA game to monogame for a long time now, and I’m pretty much buried under errors at this point.

I took a long time off from working on my game, and now when i try to build I get:

“The command ““C:…MGCB.exe” /@:“C:…Content.mgcb” /platform:Windows /outputDir:“C:\Windows” /intermediateDir:“C:\Windows” /quiet” exited with code -532462766.”

And for pretty much all my content I get “Access to the path is denied” errors.

Was something changed with Monogame that requires I change my content pipeline or directories or something? When I first transferred my game to monogame a few years back, I changed the content pipeline stuff so that it’d work for monogame, and it did work.

That’s pretty much my problem, so you can stop reading here, but I’ll keep ranting incase any of this other info helps explain anything…So to try to fix that error I thought I’d try updating to the newest version of Monogame, but during the update install I receive the following errors…

“Error opening file for writing C:\Users…C#\MonoGame\”

And if I ignore all errors, it aborts with the error “Extract:”.

I don’t intend to publish for Android, but as I’ve said I get the install aborted even when I ignore the error.

I’m running Windows 10 Home edition, have VS 2010, VS 2015 and 2017 Community installed. I’ve tried running the Monogame setup as Admin and I still receive the errors. I’ve also followed some other instructions a fellow user tried to fix a similar problem to no avail. If anyone could help me out I’d be appreciative. Thanks guys.

Oh, and when I tried to build my program using CMD, I get…

Unhandled Exception: System.UnauthorizedAccessException: Access to
the path ‘C:\Users\Z\Documents\Visual Studio
2015\Projects\Mono2DTest\Mono2DTest\Content\obj\Windows.mgcontent’ is
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalDelete(String path, Boolean checkHost)
at MGCB.BuildContent.Build(Int32& successCount, Int32& errorCount)
at MGCB.Program.Main(String[] args)

I don’t know if that’s relevant at all but I’ll post it anyway.

Anyone? I tried checking out a few solutions to similar problems I found on the forum but no dice.

Is Visual Studio or the Content Pipeline tool open when you’re updating MonoGame? It seems like the errors you’re getting are Windows denying access to a path because it’s either in use or protected in some way.

You also mentioned that you transferred your game a few years back. Did you change/reformat computers and update the referenced paths since then?

I also get this error as well, I don’t know how to fix it either, I have been trying to look but have not found anything.

Is your OS 64bit? The MonogameContentPipeline only works on 64bit Windows.

Everything was closed during the attempted update, I’ve tried running it many times as administrator, after restarting, after softbooting out of other possibly related .NET processes, and no luck…

And yeah, I updated the reference paths back then and had the monogame content pipeline working about a year ago.

Do you also see “exited with code -532462766”, or only the other access denied errors?

Yea, it’s Windows 10, 64-bit OS, x64-based processor.